Title large file check not happening when scanning
Priority bug Status resolved
Superseder Nosy List ant, poeml
Assigned To Keywords scanner

Created on 2009-10-07.20:40:18 by poeml, last changed by poeml.

msg20 (view) Author: poeml Date: 2009-10-07.20:40:18
In November 2008 I observed that the scanner didn't do the "large file check" that it 
is supposed to do for files > 2GB, when it scanned the University of Muenster mirror.

(Reported in the openSUSE bug tracker at the time, and now moved here. )

I supposed that something is special about that mirror that prevents the check from 
happening; for all other mirors it seemed to work.
msg312 (view) Author: poeml Date: 2010-11-14.16:49:16
This is probably why:

 # mb scan -d distribution/11.3/iso muenster -vv
[...] rsync ADD: 644         -1 Wed Jul  7 11:33:29 2010  
distribution/11.3/iso/openSUSE-11.3-DVD-x86_64.iso rsync ADD: 644        189 Thu Jul  8 11:01:22 2010  
distribution/11.3/iso/openSUSE-11.3-DVD-x86_64.iso.asc rsync ADD: 644         63 Sun Jul 11 07:36:12 2010  
distribution/11.3/iso/openSUSE-11.3-DVD-x86_64.iso.md5 rsync ADD: 644         71 Sun Jul 11 07:38:53 2010  
distribution/11.3/iso/openSUSE-11.3-DVD-x86_64.iso.sha1 rsync ADD: 644     343117 Thu Jul  8 10:58:43 2010  
distribution/11.3/iso/openSUSE-11.3-DVD-x86_64.iso.torrent rsync ADD: 644  716177408 Tue Jul  6 09:44:46 2010  

The rsync daemon, or the scanner, report the file size of the DVD as -1. D'oh!

Using a real rsync client, the output does not look suspicious:

 # rsync --no-motd rsync://ftp.uni-
-rw-r--r--  4346398720 2010/07/07 11:11:08 openSUSE-11.3-DVD-i586.iso

The rsync server says hello with "@RSYNCD: 30.0", which means it's not an old one.

What's worse, I see that the same "broken" length (-1) comes from other mirrors, like So 
we have a serious bug here that probably affects all mirrors running rsync 3.x (which were few, two 
years ago, but now should be most).
msg313 (view) Author: poeml Date: 2010-11-14.17:27:32
I was fooled -- it is only the display of the number which was broken. I fixed 
this in trunk (r8230).

Regarding the actual bug, I cannot reproduce it anymore: the large file check 
happens correctly with that mirror. I'll assume that something has been changed 
there and close the bug.
Date User Action Args
2010-11-14 17:27:34poemlsetstatus: deferred -> resolved
messages: + msg313
2010-11-14 16:49:17poemlsetmessages: + msg312
2009-12-07 03:16:13poemlsetstatus: unread -> deferred
2009-12-01 20:55:19poemlsetkeyword: + scanner
2009-11-04 16:33:50antsetnosy: + ant
2009-10-07 20:40:18poemlcreate