Issue57

Title 2.13.0 upgrade needs to be installed twice on Debian/Ubuntu
Priority bug Status resolved
Superseder Nosy List poeml
Assigned To poeml Keywords Packaging

Created on 2010-09-02.22:22:40 by poeml, last changed by poeml.

Messages
msg235 (view) Author: poeml Date: 2010-09-07.22:21:13
Corys fix helped. Wonderful. Thanks!
msg234 (view) Author: poeml Date: 2010-09-07.21:59:16
http://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

I'm testing the proposed fix.
msg233 (view) Author: poeml Date: 2010-09-07.21:34:29
Cory points to this documentation: http://www.debian.org/doc/debian-policy/ch-
relationships.html#s-replaces
msg210 (view) Author: poeml Date: 2010-09-02.22:24:38
(Naturally, this is only an issue when upgrading from the previous version 
(2.12.x).)
msg209 (view) Author: poeml Date: 2010-09-02.22:22:40
When updating the mirrorbrain packages on Ubuntu or Debian systems, the upgrade does not 
complete upon the first attempt. The problem is that the file /usr/bin/mb has been moved to a 
different subpackage, and apt-get doesn't want to overwrite it:


Unpacking replacement python-mb ...
dpkg: error processing /var/cache/apt/archives/python-mb_2.13.0-3_amd64.deb (--unpack):
 trying to overwrite `/usr/bin/mb', which is also in package mirrorbrain-tools
Preparing to replace mirrorbrain-tools 2.12.0-2 (using .../mirrorbrain-tools_2.13.0-
3_amd64.deb) ...
Unpacking replacement mirrorbrain-tools ...
Processing triggers for python-support ...
Errors were encountered while processing:
 /var/cache/apt/archives/python-mb_2.13.0-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



To complete the update, it is necessary to run 'apt-get upgrade' a second time. 

This may be a packaging error; I'm not sure how to solve it right now.
History
Date User Action Args
2010-09-07 22:21:13poemlsetstatus: in-progress -> resolved
messages: + msg235
2010-09-07 21:59:17poemlsetmessages: + msg234
2010-09-07 21:34:29poemlsetstatus: chatting -> in-progress
messages: + msg233
2010-09-02 22:24:38poemlsetmessages: + msg210
2010-09-02 22:22:41poemlcreate